Bug in slice and clip for mesh containing VTK_POLYHEDRON cells

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug in slice and clip for mesh containing VTK_POLYHEDRON cells

robertevanharris@gmail.com
All,

I have been dealing with grids that contain some general polyhedral cells and I find that both the slice and clip filters seem to be prone to causing core dumps in Paraview for such grids. I created a reduced dataset to reproduce the problem which can be downloaded here (~30MB).

https://drive.google.com/file/d/0BwV6xvriOEipNXZJR1ZVcXNGbWc/edit?usp=sharing

Loading in the dataset and applying a slice filter at default location and with a Z-normal will cause a core dump. This happens whether triangulated or not. Also, strangely, the crinkle slice does seem to work fine for this case. Another strange thing which may or may not be related to this is that a Y-normal slice at the default location clearly shows numerous small voids where there should in fact be cells. Somehow the slice is failing to work properly here. Any help on this is greatly appreciated.

Thanks

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|

Re: Bug in slice and clip for mesh containing VTK_POLYHEDRON cells

Gerrick Bivins

I also noticed the “gaps” but haven’t hit the crash yet.

http://vtk.1045678.n5.nabble.com/vtkCutter-leaves-quot-gaps-quot-tt5724617.html

Gerrick

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Rob Harris
Sent: Friday, December 06, 2013 11:49 AM
To: [hidden email]
Subject: [vtkusers] Bug in slice and clip for mesh containing VTK_POLYHEDRON cells

 

All,

I have been dealing with grids that contain some general polyhedral cells and I find that both the slice and clip filters seem to be prone to causing core dumps in Paraview for such grids. I created a reduced dataset to reproduce the problem which can be downloaded here (~30MB).

https://drive.google.com/file/d/0BwV6xvriOEipNXZJR1ZVcXNGbWc/edit?usp=sharing

Loading in the dataset and applying a slice filter at default location and with a Z-normal will cause a core dump. This happens whether triangulated or not. Also, strangely, the crinkle slice does seem to work fine for this case. Another strange thing which may or may not be related to this is that a Y-normal slice at the default location clearly shows numerous small voids where there should in fact be cells. Somehow the slice is failing to work properly here. Any help on this is greatly appreciated.

Thanks


This e-mail, including any attached files, may contain confidential and privileged information for the sole use of the intended recipient. Any review, use, distribution, or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive information for the intended recipient), please contact the sender by reply e-mail and delete all copies of this message.

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtkusers