Building ActiViz 6.3 | vtkRenderingFreeTypeOpenGL Problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Building ActiViz 6.3 | vtkRenderingFreeTypeOpenGL Problem

Matimont

Hi,

I was trying to build ActiViz 6.3 and I received the following error:

LINK : fatal error LNK1104: cannot open file 'vtkRenderingFreeTypeOpenGL.lib'

ActiViz 6.2 compiled just fine so it seems that the RenderingFreeTypeOpenGL module no longer exists in version VTK 6.3 and later

Any way to remove this error? I would think the ActiViz source code will need to be patched?

By the way, I'm using a an ActiViz git source I cloned back in September 2015

Thank you,

Matias.

--
Matias

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|

Re: Building ActiViz 6.3 | vtkRenderingFreeTypeOpenGL Problem

David Lonie-2
I can confirm that the module was removed, but someone more familiar with activiz will have to propose a fix.

Might work just to search through the activiz layer and remove all references to the module. Nothing new replaced it, so just stripping it out might do the trick.

HTH,
Dave

On Fri, Apr 15, 2016 at 9:27 AM, Matias Montroull <[hidden email]> wrote:

Hi,

I was trying to build ActiViz 6.3 and I received the following error:

LINK : fatal error LNK1104: cannot open file 'vtkRenderingFreeTypeOpenGL.lib'

ActiViz 6.2 compiled just fine so it seems that the RenderingFreeTypeOpenGL module no longer exists in version VTK 6.3 and later

Any way to remove this error? I would think the ActiViz source code will need to be patched?

By the way, I'm using a an ActiViz git source I cloned back in September 2015

Thank you,

Matias.

--
Matias

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|

Re: Building ActiViz 6.3 | vtkRenderingFreeTypeOpenGL Problem

Matimont
Hi David,

I compiled ActiViz 6.3 successfully, I removed the references from Cmake and "WrappedObject.cs.in" in the ActiViz source code and that seems to have done the trick..

I'm testing on my app and it works well so far.

Regards,

Matias

El mar., 19 de abr. de 2016 a la(s) 12:29, David Lonie <[hidden email]> escribió:
I can confirm that the module was removed, but someone more familiar with activiz will have to propose a fix.

Might work just to search through the activiz layer and remove all references to the module. Nothing new replaced it, so just stripping it out might do the trick.

HTH,
Dave

On Fri, Apr 15, 2016 at 9:27 AM, Matias Montroull <[hidden email]> wrote:

Hi,

I was trying to build ActiViz 6.3 and I received the following error:

LINK : fatal error LNK1104: cannot open file 'vtkRenderingFreeTypeOpenGL.lib'

ActiViz 6.2 compiled just fine so it seems that the RenderingFreeTypeOpenGL module no longer exists in version VTK 6.3 and later

Any way to remove this error? I would think the ActiViz source code will need to be patched?

By the way, I'm using a an ActiViz git source I cloned back in September 2015

Thank you,

Matias.

--
Matias

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers


--
Matias

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers