Building VTK with Intel compiler fails due to MotionFX

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Building VTK with Intel compiler fails due to MotionFX

Andreas Buykx-2

Hi,

I occasionally contribute fixes to issues in VTK. My last contributions were on the 8.2.rc2 branch end of November 2018. Today I tried to build the head of the master to look at another issue, with our current intel compiler (version 19.0.0.20181018). At first I ran into a problem that  CMake/vtkCompilerPlatformFlags.cmake uses VTK_CMAKE_DIR whereas this was renamed to vtk_cmake_dir some time ago. After I fixed that (it also appears in vtkAndroid.cmake, vtkiOS.cmake and some files under Examples/Build) I encountered the following CMake error:

 

CMake Error in IO/MotionFX/CMakeLists.txt:

  The compiler feature "cxx_generalized_initializers" is not known to CXX

  compiler

 

  "Intel"

 

  version 19.0.0.20181018.

 

Looking for the compiler feature string led me to the 3rd party library pegl. I don’t need the vtkIOMotionFX library, so I would either like to exclude it entirely or, I suppose, update the IO/MotionFX/vtk.module CONDITION entry such that it does not get built with the intel compiler(?)

 

Could someone help me to achieve this?

 

Thanks a lot!

Andreas Buykx

 

DIANA FEA BV

Software Developers and Analysis Consultants for Civil and Geotechnical Engineering

 

Delftechpark 19a, 2628XJ, Delft, The Netherlands

Tel: +31 88 34262 15 (Direct) │ Tel: +31 88 34262 00 (Switchboard) │ Fax: +31 88 34262 99

http://dianafea.com

 


_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
https://vtk.org/mailman/listinfo/vtkusers