Error with find_package(VTK) for vtk master

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Error with find_package(VTK) for vtk master

David Gobbi
Hi All,

I'm getting an error when using vtk master from an external project.
My test CMakeLists.txt is the following:

    project(TESTPROJ)
    cmake_minimum_required(VERSION 2.8.11)
    find_package(VTK REQUIRED)

The call to find_package() reports the following error:

    The following imported targets are referenced, but are missing: vtkm_cont

Is vtkm_cont meant to be a private library or is it an interface library?

  - David

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
https://public.kitware.com/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Error with find_package(VTK) for vtk master

David Gobbi
Upon further investigation, this problem with vtkm_cont goes back to
commit a2b0b7f3 on May 4: Update to latest VTK-m master


On Fri, Jun 8, 2018 at 9:01 AM, David Gobbi <[hidden email]> wrote:
Hi All,

I'm getting an error when using vtk master from an external project.
My test CMakeLists.txt is the following:

    project(TESTPROJ)
    cmake_minimum_required(VERSION 2.8.11)
    find_package(VTK REQUIRED)

The call to find_package() reports the following error:

    The following imported targets are referenced, but are missing: vtkm_cont

Is vtkm_cont meant to be a private library or is it an interface library?

  - David


_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
https://public.kitware.com/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Error with find_package(VTK) for vtk master

Robert Maynard-4
Thanks for finding what caused this, and I will look into it.

vtkm_cont is a real public library and is part of the vtk-m thirdparty
export group.
On Fri, Jun 8, 2018 at 1:22 PM David Gobbi <[hidden email]> wrote:

>
> Upon further investigation, this problem with vtkm_cont goes back to
> commit a2b0b7f3 on May 4: Update to latest VTK-m master
>
>
> On Fri, Jun 8, 2018 at 9:01 AM, David Gobbi <[hidden email]> wrote:
>>
>> Hi All,
>>
>> I'm getting an error when using vtk master from an external project.
>> My test CMakeLists.txt is the following:
>>
>>     project(TESTPROJ)
>>     cmake_minimum_required(VERSION 2.8.11)
>>     find_package(VTK REQUIRED)
>>
>> The call to find_package() reports the following error:
>>
>>     The following imported targets are referenced, but are missing: vtkm_cont
>>
>> Is vtkm_cont meant to be a private library or is it an interface library?
>>
>>   - David
>
>
> _______________________________________________
> Powered by www.kitware.com
>
> Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html
>
> Search the list archives at: http://markmail.org/search/?q=vtk-developers
>
> Follow this link to subscribe/unsubscribe:
> https://public.kitware.com/mailman/listinfo/vtk-developers
>
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
https://public.kitware.com/mailman/listinfo/vtk-developers