Gerrit test error on amber8

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Gerrit test error on amber8

David Thompson-2
Hi all,

I'm seeing an odd test error on amber8: TestPolygonSelection is failing which is unrelated to the code I checked in. It also appears to be failing for other unrelated gerrit topics:

http://open.cdash.org/testDetails.php?test=186977515&build=2890285
http://open.cdash.org/testDetails.php?test=187458615&build=2890244

Are there any known issues with amber8's hardware or test environment?

        Thanks,
        David
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Gerrit test error on amber8

Yumin Yuan
Hi Dave,

That test is for the new polygon-selection feature in VTK I added last week, I also noticed the odd (somewhat random) failure of this test on amber8 when I pushed to Gerrit, and I talked with Marcus a little bit, and he thought it may be related to the mesa library that amber8 is running. I have not spent time to track down the issue, but since this test is passing on all nightly dashboard machines, I think you can ignore it for the stuff you are working on. I will try to track it down when I get some free time.

Yumin


On Mon, Apr 29, 2013 at 12:37 PM, David Thompson <[hidden email]> wrote:
Hi all,

I'm seeing an odd test error on amber8: TestPolygonSelection is failing which is unrelated to the code I checked in. It also appears to be failing for other unrelated gerrit topics:

http://open.cdash.org/testDetails.php?test=186977515&build=2890285
http://open.cdash.org/testDetails.php?test=187458615&build=2890244

Are there any known issues with amber8's hardware or test environment?

        Thanks,
        David
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Gerrit test error on amber8

Bill Lorensen
Having intermittent gerrit test failures is not good. It would be great to raise the priority of this. We spent a lot of time recently to get the gerrit builds to 0 test failures.



On Mon, Apr 29, 2013 at 1:05 PM, Yumin Yuan <[hidden email]> wrote:
Hi Dave,

That test is for the new polygon-selection feature in VTK I added last week, I also noticed the odd (somewhat random) failure of this test on amber8 when I pushed to Gerrit, and I talked with Marcus a little bit, and he thought it may be related to the mesa library that amber8 is running. I have not spent time to track down the issue, but since this test is passing on all nightly dashboard machines, I think you can ignore it for the stuff you are working on. I will try to track it down when I get some free time.

Yumin


On Mon, Apr 29, 2013 at 12:37 PM, David Thompson <[hidden email]> wrote:
Hi all,

I'm seeing an odd test error on amber8: TestPolygonSelection is failing which is unrelated to the code I checked in. It also appears to be failing for other unrelated gerrit topics:

http://open.cdash.org/testDetails.php?test=186977515&build=2890285
http://open.cdash.org/testDetails.php?test=187458615&build=2890244

Are there any known issues with amber8's hardware or test environment?

        Thanks,
        David
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers





--
Unpaid intern in BillsBasement at noware dot com

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Gerrit test error on amber8

David Thompson-2
In reply to this post by Yumin Yuan
Hi Yumin,

> That test is for the new polygon-selection feature in VTK I added last week, ... it may be related to the mesa library that amber8 is running. ... you can ignore it for the stuff you are working on. I will try to track it down when I get some free time.

Thanks, and good hunting. :-)

        David


> On Mon, Apr 29, 2013 at 12:37 PM, David Thompson <[hidden email]> wrote:
> Hi all,
>
> I'm seeing an odd test error on amber8: TestPolygonSelection is failing which is unrelated to the code I checked in. It also appears to be failing for other unrelated gerrit topics:
>
> http://open.cdash.org/testDetails.php?test=186977515&build=2890285
> http://open.cdash.org/testDetails.php?test=187458615&build=2890244
>
> Are there any known issues with amber8's hardware or test environment?

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Gerrit test error on amber8

Yumin Yuan
In reply to this post by Bill Lorensen
Hi Bill,
Yes, I agree. I will find some time to get on that machine next couple days. If it is really related to Mesa, I will suppress this test on that machine.

Yumin


On Mon, Apr 29, 2013 at 1:45 PM, Bill Lorensen <[hidden email]> wrote:
Having intermittent gerrit test failures is not good. It would be great to raise the priority of this. We spent a lot of time recently to get the gerrit builds to 0 test failures.



On Mon, Apr 29, 2013 at 1:05 PM, Yumin Yuan <[hidden email]> wrote:
Hi Dave,

That test is for the new polygon-selection feature in VTK I added last week, I also noticed the odd (somewhat random) failure of this test on amber8 when I pushed to Gerrit, and I talked with Marcus a little bit, and he thought it may be related to the mesa library that amber8 is running. I have not spent time to track down the issue, but since this test is passing on all nightly dashboard machines, I think you can ignore it for the stuff you are working on. I will try to track it down when I get some free time.

Yumin


On Mon, Apr 29, 2013 at 12:37 PM, David Thompson <[hidden email]> wrote:
Hi all,

I'm seeing an odd test error on amber8: TestPolygonSelection is failing which is unrelated to the code I checked in. It also appears to be failing for other unrelated gerrit topics:

http://open.cdash.org/testDetails.php?test=186977515&build=2890285
http://open.cdash.org/testDetails.php?test=187458615&build=2890244

Are there any known issues with amber8's hardware or test environment?

        Thanks,
        David
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers





--
Unpaid intern in BillsBasement at noware dot com


_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Gerrit test error on amber8

Yumin Yuan
Just want to update on this. I have spent some decent time trying to track it down without much success. The fact that the test passes if I run manually on amber8, either individually or in a list of tests, makes it very difficult to reproduce. I have trimmed down the test to minimum and played around with different openGL calls, but it still intermittently fails when running ctest.

Given the fact that this test passes on all other dashboard machines, we decided to exclude it from amber8 gerrit-dashboard. We still think this is Mesa/openGL related, and I will set up one of my own machines with the same environment as amber-8 and investigate further.

Sorry for the inconvenience.
Yumin


On Mon, Apr 29, 2013 at 3:51 PM, Yumin Yuan <[hidden email]> wrote:
Hi Bill,
Yes, I agree. I will find some time to get on that machine next couple days. If it is really related to Mesa, I will suppress this test on that machine.

Yumin


On Mon, Apr 29, 2013 at 1:45 PM, Bill Lorensen <[hidden email]> wrote:
Having intermittent gerrit test failures is not good. It would be great to raise the priority of this. We spent a lot of time recently to get the gerrit builds to 0 test failures.



On Mon, Apr 29, 2013 at 1:05 PM, Yumin Yuan <[hidden email]> wrote:
Hi Dave,

That test is for the new polygon-selection feature in VTK I added last week, I also noticed the odd (somewhat random) failure of this test on amber8 when I pushed to Gerrit, and I talked with Marcus a little bit, and he thought it may be related to the mesa library that amber8 is running. I have not spent time to track down the issue, but since this test is passing on all nightly dashboard machines, I think you can ignore it for the stuff you are working on. I will try to track it down when I get some free time.

Yumin


On Mon, Apr 29, 2013 at 12:37 PM, David Thompson <[hidden email]> wrote:
Hi all,

I'm seeing an odd test error on amber8: TestPolygonSelection is failing which is unrelated to the code I checked in. It also appears to be failing for other unrelated gerrit topics:

http://open.cdash.org/testDetails.php?test=186977515&build=2890285
http://open.cdash.org/testDetails.php?test=187458615&build=2890244

Are there any known issues with amber8's hardware or test environment?

        Thanks,
        David
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers





--
Unpaid intern in BillsBasement at noware dot com



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Gerrit test error on amber8

guru rajan-2

Please. Unsunscribe me from vtk or its

Sent from my Sony Xperia™ smartphone



---- Yumin Yuan wrote ----

Just want to update on this. I have spent some decent time trying to track it down without much success. The fact that the test passes if I run manually on amber8, either individually or in a list of tests, makes it very difficult to reproduce. I have trimmed down the test to minimum and played around with different openGL calls, but it still intermittently fails when running ctest.

Given the fact that this test passes on all other dashboard machines, we decided to exclude it from amber8 gerrit-dashboard. We still think this is Mesa/openGL related, and I will set up one of my own machines with the same environment as amber-8 and investigate further.

Sorry for the inconvenience.
Yumin


On Mon, Apr 29, 2013 at 3:51 PM, Yumin Yuan <[hidden email]> wrote:
Hi Bill,
Yes, I agree. I will find some time to get on that machine next couple days. If it is really related to Mesa, I will suppress this test on that machine.

Yumin


On Mon, Apr 29, 2013 at 1:45 PM, Bill Lorensen <[hidden email]> wrote:
Having intermittent gerrit test failures is not good. It would be great to raise the priority of this. We spent a lot of time recently to get the gerrit builds to 0 test failures.



On Mon, Apr 29, 2013 at 1:05 PM, Yumin Yuan <[hidden email]> wrote:
Hi Dave,

That test is for the new polygon-selection feature in VTK I added last week, I also noticed the odd (somewhat random) failure of this test on amber8 when I pushed to Gerrit, and I talked with Marcus a little bit, and he thought it may be related to the mesa library that amber8 is running. I have not spent time to track down the issue, but since this test is passing on all nightly dashboard machines, I think you can ignore it for the stuff you are working on. I will try to track it down when I get some free time.

Yumin


On Mon, Apr 29, 2013 at 12:37 PM, David Thompson <[hidden email]> wrote:
Hi all,

I'm seeing an odd test error on amber8: TestPolygonSelection is failing which is unrelated to the code I checked in. It also appears to be failing for other unrelated gerrit topics:

http://open.cdash.org/testDetails.php?test=186977515&build=2890285
http://open.cdash.org/testDetails.php?test=187458615&build=2890244

Are there any known issues with amber8's hardware or test environment?

        Thanks,
        David
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtk-developers





--
Unpaid intern in BillsBasement at noware dot com



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Gerrit test error on amber8

VTK - Dev mailing list
You may unsubscribe from the VTK Users list on this page:
http://www.vtk.org/mailman/listinfo/vtkusers



On Tue, May 5, 2015 at 6:02 AM, Gru <[hidden email]> wrote:

> Please. Unsunscribe me from vtk or its
>
> Sent from my Sony Xperia™ smartphone
>
>
>
> ---- Yumin Yuan wrote ----
>
> Just want to update on this. I have spent some decent time trying to track
> it down without much success. The fact that the test passes if I run
> manually on amber8, either individually or in a list of tests, makes it very
> difficult to reproduce. I have trimmed down the test to minimum and played
> around with different openGL calls, but it still intermittently fails when
> running ctest.
>
> Given the fact that this test passes on all other dashboard machines, we
> decided to exclude it from amber8 gerrit-dashboard. We still think this is
> Mesa/openGL related, and I will set up one of my own machines with the same
> environment as amber-8 and investigate further.
>
> Sorry for the inconvenience.
> Yumin
>
>
> On Mon, Apr 29, 2013 at 3:51 PM, Yumin Yuan <[hidden email]> wrote:
>>
>> Hi Bill,
>> Yes, I agree. I will find some time to get on that machine next couple
>> days. If it is really related to Mesa, I will suppress this test on that
>> machine.
>>
>> Yumin
>>
>>
>> On Mon, Apr 29, 2013 at 1:45 PM, Bill Lorensen <[hidden email]>
>> wrote:
>>>
>>> Having intermittent gerrit test failures is not good. It would be great
>>> to raise the priority of this. We spent a lot of time recently to get the
>>> gerrit builds to 0 test failures.
>>>
>>>
>>>
>>> On Mon, Apr 29, 2013 at 1:05 PM, Yumin Yuan <[hidden email]>
>>> wrote:
>>>>
>>>> Hi Dave,
>>>>
>>>> That test is for the new polygon-selection feature in VTK I added last
>>>> week, I also noticed the odd (somewhat random) failure of this test on
>>>> amber8 when I pushed to Gerrit, and I talked with Marcus a little bit, and
>>>> he thought it may be related to the mesa library that amber8 is running. I
>>>> have not spent time to track down the issue, but since this test is passing
>>>> on all nightly dashboard machines, I think you can ignore it for the stuff
>>>> you are working on. I will try to track it down when I get some free time.
>>>>
>>>> Yumin
>>>>
>>>>
>>>> On Mon, Apr 29, 2013 at 12:37 PM, David Thompson
>>>> <[hidden email]> wrote:
>>>>>
>>>>> Hi all,
>>>>>
>>>>> I'm seeing an odd test error on amber8: TestPolygonSelection is failing
>>>>> which is unrelated to the code I checked in. It also appears to be failing
>>>>> for other unrelated gerrit topics:
>>>>>
>>>>> http://open.cdash.org/testDetails.php?test=186977515&build=2890285
>>>>> http://open.cdash.org/testDetails.php?test=187458615&build=2890244
>>>>>
>>>>> Are there any known issues with amber8's hardware or test environment?
>>>>>
>>>>>         Thanks,
>>>>>         David
>>>>> _______________________________________________
>>>>> Powered by www.kitware.com
>>>>>
>>>>> Visit other Kitware open-source projects at
>>>>> http://www.kitware.com/opensource/opensource.html
>>>>>
>>>>> Follow this link to subscribe/unsubscribe:
>>>>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> Powered by www.kitware.com
>>>>
>>>> Visit other Kitware open-source projects at
>>>> http://www.kitware.com/opensource/opensource.html
>>>>
>>>> Follow this link to subscribe/unsubscribe:
>>>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> Unpaid intern in BillsBasement at noware dot com
>>
>>
>
>
> _______________________________________________
> Powered by www.kitware.com
>
> Visit other Kitware open-source projects at
> http://www.kitware.com/opensource/opensource.html
>
> Search the list archives at: http://markmail.org/search/?q=vtk-developers
>
> Follow this link to subscribe/unsubscribe:
> http://public.kitware.com/mailman/listinfo/vtk-developers
>
>
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Gerrit test error on amber8

VTK - Dev mailing list
Or from the developer's list on this page:

http://www.vtk.org/mailman/listinfo/vtk-developers



On Wed, May 6, 2015 at 7:37 AM, David Cole <[hidden email]> wrote:

> You may unsubscribe from the VTK Users list on this page:
> http://www.vtk.org/mailman/listinfo/vtkusers
>
>
>
> On Tue, May 5, 2015 at 6:02 AM, Gru <[hidden email]> wrote:
>> Please. Unsunscribe me from vtk or its
>>
>> Sent from my Sony Xperia™ smartphone
>>
>>
>>
>> ---- Yumin Yuan wrote ----
>>
>> Just want to update on this. I have spent some decent time trying to track
>> it down without much success. The fact that the test passes if I run
>> manually on amber8, either individually or in a list of tests, makes it very
>> difficult to reproduce. I have trimmed down the test to minimum and played
>> around with different openGL calls, but it still intermittently fails when
>> running ctest.
>>
>> Given the fact that this test passes on all other dashboard machines, we
>> decided to exclude it from amber8 gerrit-dashboard. We still think this is
>> Mesa/openGL related, and I will set up one of my own machines with the same
>> environment as amber-8 and investigate further.
>>
>> Sorry for the inconvenience.
>> Yumin
>>
>>
>> On Mon, Apr 29, 2013 at 3:51 PM, Yumin Yuan <[hidden email]> wrote:
>>>
>>> Hi Bill,
>>> Yes, I agree. I will find some time to get on that machine next couple
>>> days. If it is really related to Mesa, I will suppress this test on that
>>> machine.
>>>
>>> Yumin
>>>
>>>
>>> On Mon, Apr 29, 2013 at 1:45 PM, Bill Lorensen <[hidden email]>
>>> wrote:
>>>>
>>>> Having intermittent gerrit test failures is not good. It would be great
>>>> to raise the priority of this. We spent a lot of time recently to get the
>>>> gerrit builds to 0 test failures.
>>>>
>>>>
>>>>
>>>> On Mon, Apr 29, 2013 at 1:05 PM, Yumin Yuan <[hidden email]>
>>>> wrote:
>>>>>
>>>>> Hi Dave,
>>>>>
>>>>> That test is for the new polygon-selection feature in VTK I added last
>>>>> week, I also noticed the odd (somewhat random) failure of this test on
>>>>> amber8 when I pushed to Gerrit, and I talked with Marcus a little bit, and
>>>>> he thought it may be related to the mesa library that amber8 is running. I
>>>>> have not spent time to track down the issue, but since this test is passing
>>>>> on all nightly dashboard machines, I think you can ignore it for the stuff
>>>>> you are working on. I will try to track it down when I get some free time.
>>>>>
>>>>> Yumin
>>>>>
>>>>>
>>>>> On Mon, Apr 29, 2013 at 12:37 PM, David Thompson
>>>>> <[hidden email]> wrote:
>>>>>>
>>>>>> Hi all,
>>>>>>
>>>>>> I'm seeing an odd test error on amber8: TestPolygonSelection is failing
>>>>>> which is unrelated to the code I checked in. It also appears to be failing
>>>>>> for other unrelated gerrit topics:
>>>>>>
>>>>>> http://open.cdash.org/testDetails.php?test=186977515&build=2890285
>>>>>> http://open.cdash.org/testDetails.php?test=187458615&build=2890244
>>>>>>
>>>>>> Are there any known issues with amber8's hardware or test environment?
>>>>>>
>>>>>>         Thanks,
>>>>>>         David
>>>>>> _______________________________________________
>>>>>> Powered by www.kitware.com
>>>>>>
>>>>>> Visit other Kitware open-source projects at
>>>>>> http://www.kitware.com/opensource/opensource.html
>>>>>>
>>>>>> Follow this link to subscribe/unsubscribe:
>>>>>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> Powered by www.kitware.com
>>>>>
>>>>> Visit other Kitware open-source projects at
>>>>> http://www.kitware.com/opensource/opensource.html
>>>>>
>>>>> Follow this link to subscribe/unsubscribe:
>>>>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Unpaid intern in BillsBasement at noware dot com
>>>
>>>
>>
>>
>> _______________________________________________
>> Powered by www.kitware.com
>>
>> Visit other Kitware open-source projects at
>> http://www.kitware.com/opensource/opensource.html
>>
>> Search the list archives at: http://markmail.org/search/?q=vtk-developers
>>
>> Follow this link to subscribe/unsubscribe:
>> http://public.kitware.com/mailman/listinfo/vtk-developers
>>
>>
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers