In iOS volume rendering can not work in 7.1 and 7.1.1

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

In iOS volume rendering can not work in 7.1 and 7.1.1

Blade Whistler
Hi

I use the volume rendering (VTK 7.0) in iOS for my application. it works well.
 
I'm trying to update to 7.1 or 7.1.1, since in 7.0 I found the clipping is not work in 7.0. An error will occur when compiling the shader, the error is ''<' does not operate on 'float' and 'int' ". I modifed the shader in 'vtkVolumeShaderComposer.h' to make it pass, but the clipping performance is poor.

When compiling the 7.1 and 7.1.1 in iOS, the volume rendering is not default enabled, I need to modified in vtkiOS.cmake to make it compile.

After compile, when I run volume rendering in iOS, there are still has shader compiling problems. I changed the shader (mostly change the 0 to 0.0) to bypass the error, but see nothing on the screen. It seems in latest version of VTK the volume rendering is not working anymore in iOS.


Leon

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: In iOS volume rendering can not work in 7.1 and 7.1.1

Ken Martin
There is a topic in testing with some fixes for iOS, hopefully that will fix the issues you are seeing.

On Mon, Apr 3, 2017 at 2:45 AM, Blade Whistler <[hidden email]> wrote:
Hi

I use the volume rendering (VTK 7.0) in iOS for my application. it works well.
 
I'm trying to update to 7.1 or 7.1.1, since in 7.0 I found the clipping is not work in 7.0. An error will occur when compiling the shader, the error is ''<' does not operate on 'float' and 'int' ". I modifed the shader in 'vtkVolumeShaderComposer.h' to make it pass, but the clipping performance is poor.

When compiling the 7.1 and 7.1.1 in iOS, the volume rendering is not default enabled, I need to modified in vtkiOS.cmake to make it compile.

After compile, when I run volume rendering in iOS, there are still has shader compiling problems. I changed the shader (mostly change the 0 to 0.0) to bypass the error, but see nothing on the screen. It seems in latest version of VTK the volume rendering is not working anymore in iOS.


Leon

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers




--
Ken Martin PhD
Distinguished Engineer
Kitware Inc.
28 Corporate Drive
Clifton Park NY 12065

This communication, including all attachments, contains confidential and legally privileged information, and it is intended only for the use of the addressee.  Access to this email by anyone else is unauthorized. If you are not the intended recipient, any disclosure, copying, distribution or any action taken in reliance on it is prohibited and may be unlawful. If you received this communication in error please notify us immediately and destroy the original message.  Thank you.

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: In iOS volume rendering can not work in 7.1 and 7.1.1

Blade Whistler
Thanks Ken, I will try to find that topic to see if it can resolve my problem.

Leon

On Fri, Apr 7, 2017 at 2:37 AM, Ken Martin <[hidden email]> wrote:
There is a topic in testing with some fixes for iOS, hopefully that will fix the issues you are seeing.

On Mon, Apr 3, 2017 at 2:45 AM, Blade Whistler <[hidden email]> wrote:
Hi

I use the volume rendering (VTK 7.0) in iOS for my application. it works well.
 
I'm trying to update to 7.1 or 7.1.1, since in 7.0 I found the clipping is not work in 7.0. An error will occur when compiling the shader, the error is ''<' does not operate on 'float' and 'int' ". I modifed the shader in 'vtkVolumeShaderComposer.h' to make it pass, but the clipping performance is poor.

When compiling the 7.1 and 7.1.1 in iOS, the volume rendering is not default enabled, I need to modified in vtkiOS.cmake to make it compile.

After compile, when I run volume rendering in iOS, there are still has shader compiling problems. I changed the shader (mostly change the 0 to 0.0) to bypass the error, but see nothing on the screen. It seems in latest version of VTK the volume rendering is not working anymore in iOS.


Leon

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers




--
Ken Martin PhD
Distinguished Engineer
Kitware Inc.
28 Corporate Drive
Clifton Park NY 12065

This communication, including all attachments, contains confidential and legally privileged information, and it is intended only for the use of the addressee.  Access to this email by anyone else is unauthorized. If you are not the intended recipient, any disclosure, copying, distribution or any action taken in reliance on it is prohibited and may be unlawful. If you received this communication in error please notify us immediately and destroy the original message.  Thank you.


_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: In iOS volume rendering can not work in 7.1 and 7.1.1

Ken Martin
Max Smolens is working on it. He was still making some changes yesterday so I think it is still in progress. But at least it is, in progress :-)  The link is



On Fri, Apr 7, 2017 at 9:26 AM, Blade Whistler <[hidden email]> wrote:
Thanks Ken, I will try to find that topic to see if it can resolve my problem.

Leon

On Fri, Apr 7, 2017 at 2:37 AM, Ken Martin <[hidden email]> wrote:
There is a topic in testing with some fixes for iOS, hopefully that will fix the issues you are seeing.

On Mon, Apr 3, 2017 at 2:45 AM, Blade Whistler <[hidden email]> wrote:
Hi

I use the volume rendering (VTK 7.0) in iOS for my application. it works well.
 
I'm trying to update to 7.1 or 7.1.1, since in 7.0 I found the clipping is not work in 7.0. An error will occur when compiling the shader, the error is ''<' does not operate on 'float' and 'int' ". I modifed the shader in 'vtkVolumeShaderComposer.h' to make it pass, but the clipping performance is poor.

When compiling the 7.1 and 7.1.1 in iOS, the volume rendering is not default enabled, I need to modified in vtkiOS.cmake to make it compile.

After compile, when I run volume rendering in iOS, there are still has shader compiling problems. I changed the shader (mostly change the 0 to 0.0) to bypass the error, but see nothing on the screen. It seems in latest version of VTK the volume rendering is not working anymore in iOS.


Leon

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers




--
Ken Martin PhD
Distinguished Engineer
Kitware Inc.
28 Corporate Drive
Clifton Park NY 12065

This communication, including all attachments, contains confidential and legally privileged information, and it is intended only for the use of the addressee.  Access to this email by anyone else is unauthorized. If you are not the intended recipient, any disclosure, copying, distribution or any action taken in reliance on it is prohibited and may be unlawful. If you received this communication in error please notify us immediately and destroy the original message.  Thank you.




--
Ken Martin PhD
Distinguished Engineer
Kitware Inc.
28 Corporate Drive
Clifton Park NY 12065

This communication, including all attachments, contains confidential and legally privileged information, and it is intended only for the use of the addressee.  Access to this email by anyone else is unauthorized. If you are not the intended recipient, any disclosure, copying, distribution or any action taken in reliance on it is prohibited and may be unlawful. If you received this communication in error please notify us immediately and destroy the original message.  Thank you.

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: In iOS volume rendering can not work in 7.1 and 7.1.1

Blade Whistler
Got it. Thanks. That's exactly the problem I have.

On Fri, Apr 7, 2017 at 10:03 PM, Ken Martin <[hidden email]> wrote:
Max Smolens is working on it. He was still making some changes yesterday so I think it is still in progress. But at least it is, in progress :-)  The link is



On Fri, Apr 7, 2017 at 9:26 AM, Blade Whistler <[hidden email]> wrote:
Thanks Ken, I will try to find that topic to see if it can resolve my problem.

Leon

On Fri, Apr 7, 2017 at 2:37 AM, Ken Martin <[hidden email]> wrote:
There is a topic in testing with some fixes for iOS, hopefully that will fix the issues you are seeing.

On Mon, Apr 3, 2017 at 2:45 AM, Blade Whistler <[hidden email]> wrote:
Hi

I use the volume rendering (VTK 7.0) in iOS for my application. it works well.
 
I'm trying to update to 7.1 or 7.1.1, since in 7.0 I found the clipping is not work in 7.0. An error will occur when compiling the shader, the error is ''<' does not operate on 'float' and 'int' ". I modifed the shader in 'vtkVolumeShaderComposer.h' to make it pass, but the clipping performance is poor.

When compiling the 7.1 and 7.1.1 in iOS, the volume rendering is not default enabled, I need to modified in vtkiOS.cmake to make it compile.

After compile, when I run volume rendering in iOS, there are still has shader compiling problems. I changed the shader (mostly change the 0 to 0.0) to bypass the error, but see nothing on the screen. It seems in latest version of VTK the volume rendering is not working anymore in iOS.


Leon

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers




--
Ken Martin PhD
Distinguished Engineer
Kitware Inc.
28 Corporate Drive
Clifton Park NY 12065

This communication, including all attachments, contains confidential and legally privileged information, and it is intended only for the use of the addressee.  Access to this email by anyone else is unauthorized. If you are not the intended recipient, any disclosure, copying, distribution or any action taken in reliance on it is prohibited and may be unlawful. If you received this communication in error please notify us immediately and destroy the original message.  Thank you.




--
Ken Martin PhD
Distinguished Engineer
Kitware Inc.
28 Corporate Drive
Clifton Park NY 12065

This communication, including all attachments, contains confidential and legally privileged information, and it is intended only for the use of the addressee.  Access to this email by anyone else is unauthorized. If you are not the intended recipient, any disclosure, copying, distribution or any action taken in reliance on it is prohibited and may be unlawful. If you received this communication in error please notify us immediately and destroy the original message.  Thank you.


_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtkusers
Loading...