Quantcast

OffScreenRendering crash on CircleCI (Mac OSX)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

OffScreenRendering crash on CircleCI (Mac OSX)

Sankhesh Jhaveri-2

Folks,

We’re running into a strange crash on mac containers (OSX 10.11.6) created by CircleCI with VTK (OpenGL backend).

VTK compiles fine and seems to work with OffScreenRenderingOff but crashes at the first OpenGL call with OffScreenRenderingOn(). Unfortunately, I can’t reproduce this on my mac machine and haven’t been able to make headway within the half hour that CircleCI provides.

Again, this is the OpenGL backend. No crashes with the OpenGL2 backend.
If anyone has come across this or has an idea how to debug/reproduce/fix this, kindly drop me a hint.

Thanks,
Sankhesh

--
Sankhesh Jhaveri
Sr. Research & Development Engineer | Kitware | (518) 881-4417

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OffScreenRendering crash on CircleCI (Mac OSX)

Sean McBride
On Wed, 5 Apr 2017 20:57:55 +0000, Sankhesh Jhaveri said:

>We’re running into a strange crash on mac containers (OSX 10.11.6) created
>by CircleCI with VTK (OpenGL backend).
>
>VTK compiles fine and seems to work with OffScreenRenderingOff but crashes
>at the first OpenGL call with OffScreenRenderingOn(). Unfortunately, I
>can’t reproduce this on my mac machine and haven’t been able to make
>headway within the half hour that CircleCI provides.
>
>Again, this is the OpenGL backend. No crashes with the OpenGL2 backend.
>If anyone has come across this or has an idea how to debug/reproduce/fix
>this, kindly drop me a hint.

Sankhesh,

You don't give enough information for anyone to help you.  If you can't reproduce, what can any of us say if we don't even have your code?  :)  How about at least a backtrace of the crash, that might be something someone recognises.

Cheers,

--
____________________________________________________________
Sean McBride, B. Eng                 [hidden email]
Rogue Research                        www.rogue-research.com
Mac Software Developer              Montréal, Québec, Canada
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OffScreenRendering crash on CircleCI (Mac OSX)

Sankhesh Jhaveri-2
Hi Sean,

I understand. The issue is cataloged here: https://github.com/UV-CDAT/vcs/issues/130

The issue only occurs on a CircleCI provisioned container and I was unable to reproduce it on a physical machine. By asking this question here, I wanted to see if anyone else has come across and tackled this issue.

Since my previous email, I was able to test a sample OpenGL application and reproduce the crash on a CircleCI VM, indicating it is an opengl/driver issue specific to circleci machines.

Thanks,
Sankhesh


On Thu, Apr 6, 2017 at 3:38 PM Sean McBride <[hidden email]> wrote:
On Wed, 5 Apr 2017 20:57:55 +0000, Sankhesh Jhaveri said:

>We’re running into a strange crash on mac containers (OSX 10.11.6) created
>by CircleCI with VTK (OpenGL backend).
>
>VTK compiles fine and seems to work with OffScreenRenderingOff but crashes
>at the first OpenGL call with OffScreenRenderingOn(). Unfortunately, I
>can’t reproduce this on my mac machine and haven’t been able to make
>headway within the half hour that CircleCI provides.
>
>Again, this is the OpenGL backend. No crashes with the OpenGL2 backend.
>If anyone has come across this or has an idea how to debug/reproduce/fix
>this, kindly drop me a hint.

Sankhesh,

You don't give enough information for anyone to help you.  If you can't reproduce, what can any of us say if we don't even have your code?  :)  How about at least a backtrace of the crash, that might be something someone recognises.

Cheers,

--
____________________________________________________________
Sean McBride, B. Eng                 [hidden email]
Rogue Research                        www.rogue-research.com
Mac Software Developer              Montréal, Québec, Canada
--
Sankhesh Jhaveri
Sr. Research & Development Engineer | Kitware | (518) 881-4417

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers

Loading...