Quantcast

Re: Texture Mapping Problem....Please Help !!!!!

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Texture Mapping Problem....Please Help !!!!!

cdeepakroy
Hello Marc,
 
Thanks for the reply.
 
I started working back on this texture issue now, which set aside due to other high priority work.
 
But when i visualize these surface models, in third party vrml viewers the texture comes out well. Its only in my program that i find these pattern of cracks.
 
What do you think could be the problem ?
 
Regards,
 
Deepak

Marc Cotran <[hidden email]> wrote:
Hi Deepak,

I had experienced similar results before and concluded that the polygon
normals were the culprit. I would suggest visualizing the polydata mesh
in wireframe to see if some of your polygons are oriented opposite to
the others. I am not sure this is what you're dealing with, but it might
explain your problem. As for a potential solution... I am at a loss.

Should you figure out the problem, I'd love to know the solution.

HTH,

Marc

Deepak Roy wrote:

>
> Hello everyone,
>
> I have had a hard time trying to fix this texture display problem.
>
> Attached is a part of the texture image i am using for the human body.
> I have removed the face and other parts due to some identity revealment
> problems.
>
> But the image gives an idea of the problem i am facing. Look at the
> image and you will see the cracks on the texture.
>
> when i visualize the same model in some other standard graphics software
> like Rapid Forms, the texture shows up with out any cracks.
>
> I have tried all the possible options with vtkTexture but still i could
> not fix the problem.
>
> /"Can anyone explain this phenomenon ? "/
>
> One more point to note, which i also mentioned in my previous posting to
> the mailing list, is that exactly the same pattern of cracks appear in
> every model i load.
>
> I suspect, it is got to do with clamping or interpolation.
>
> Please help me fix this problem.
>
> Thanks in Advance.
>
> Regards,
>
> Deepak Roy
>
>
>
>
> Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
>
>
> ------------------------------------------------------------------------
>
> Subject:
> Texture Mapping Problem....Please Help !!!!!
> From:
> Deepak Roy
> Date:
> Fri, 14 Oct 2005 15:42:33 -0700 (PDT)
> To:
> [hidden email]
>
> To:
> [hidden email]
>
>
> Hi,
>
> I am trying to displaying a 3D surface of a human body with texture, all
> captured from a 3D scan. I am using vtkTecture to assosciate the actor
> with the texture.
>
> The problem is:
>
> I see a pattern of cracks on surface when displayed with texture. These
> cracks are not present in the basic geometry of the model as the surface
> when visualised without texture appears fine and smooth. I am 100% sure
> that this is the problem with texture mapping.
>
> One more thing that was wierd was that i see more or less the same
> pattern of tracks on each model i display.
>
> Could anyone explain the reason why this is happening?
>
> I guess the problem is with the edge clamping used while mapping the
> texture. But vtkTexture does not give me any control on how to change
> these parameters.
>
> How can i change the these parameters and control the way texture
> mapping is done. Is there an easy way to do this?
>
> Thanks in Advance.
>
> Regards
>
> Deepak
>
>
> Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
>
>
> ------------------------------------------------------------------------
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> This is the private VTK discussion list.
> Please keep messages on-topic. Check the FAQ at: http://www.vtk.org/Wiki/VTK_FAQ
> Follow this link to subscribe/unsubscribe:
> http://www.vtk.org/mailman/listinfo/vtkusers


Yahoo! Photos – Showcase holiday pictures in hardcover
Photo Books. You design it and we’ll bind it!
_______________________________________________
This is the private VTK discussion list.
Please keep messages on-topic. Check the FAQ at: http://www.vtk.org/Wiki/VTK_FAQ
Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Texture Mapping Problem....Please Help !!!!!

cdeepakroy
Hi again Marc,
 
I tried the vtkQuadricDecimation Filter with various target reductions -- 0.2, 0.5, 0.8, 0.9.
 
But if i decimate using this filter and then try to display with the texture.........the texture does not show up at all.
 
It looks like it is displayed in uniform color.
 
Waiting for your reply.
 
Regards,
 
Deepak


Marc Cotran <[hidden email]> wrote:
Deepak Roy wrote:

> But when i visualize these surface models, in third party vrml viewers
> the texture comes out well. Its only in my program that i find these
> pattern of cracks.
> What do you think could be the problem ?

Hi again Deepak,

Something you could try... Run your vtkPolyData through the
vtkQuadricDecimation filter with an insignificant target reduction. I
was able to clean up some of my models using this technique, though
still haven't figured out *why* it works.

hth

Marc

>
> */Marc Cotran /* wrote:
>
> Hi Deepak,
>
> I had experienced similar results before and concluded that the
> polygon
> normals were the culprit. I would suggest visualizing the polydata
> mesh
> in wireframe to see if some of your polygons are oriented opposite to
> the others. I am not sure this is what you're dealing with, but it
> might
> explain your problem. As for a potential solution... I am at a loss.
>
> Should you figure out the problem, I'd love to know the solution.
>
> HTH,
>
> Marc
>
> Deepak Roy wrote:
> >
> > Hello everyone,
> >
> > I have had a hard time trying to fix this texture display problem.
> >
> > Attached is a part of the texture image i am using for the human
> body.
> > I have removed the face and other parts due to some identity
> revealment
> > problems.
> >
> > But the image gives an idea of the problem i am facing. Look at the
> > image and you will see the cracks on the texture.
> >
> > when i visualize the same model in some other standard graphics
> software
> > like Rapid Forms, the texture shows up with out any cracks.
> >
> > I have tried all the possible options with vtkTexture but still
> i could
> > not fix the problem.
> >
> > /"Can anyone explain this phenomenon ? "/
> >
> > One more point to note, which i also mentioned in my previous
> posting to
> > the mailing list, is that exactly the same pattern of cracks
> appear in
> > every model i load.
> >
> > I suspect, it is got to do with clamping or interpolation.
> >
> > Please help me fix this problem.
> >
> > Thanks in Advance.
> >
> > Regards,
> >
> > Deepak Roy
> >
> >
> >
> >
> > Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
> >
> >
> >
> ------------------------------------------------------------------------
> >
> > Subject:
> > Texture Mapping Problem....Please Help !!!!!
> > From:
> > Deepak Roy
> > Date:
> > Fri, 14 Oct 2005 15:42:33 -0700 (PDT)
> > To:
> > [hidden email]
> >
> > To:
> > [hidden email]
> >
> >
> > Hi,
> >
> > I am trying to displaying a 3D surface of a human body with
> texture, all
> > captured from a 3D scan. I am using vtkTecture to assosciate the
> actor
> > with the texture.
> >
> > The problem is:
> >
> > I see a pattern of cracks on surface when displayed with
> texture. These
> > cracks are not present in the basic geometry of the model as the
> surface
> > when visualised without texture appears fine and smooth. I am
> 100% sure
> > that this is the problem with texture mapping.
> >
> > One more thing that was wierd was that i see more or less the same
> > pattern of tracks on each model i display.
> >
> > Could anyone explain the reason why this is happening?
> >
> > I guess the problem is with the edge clamping used while mapping
> the
> > texture. But vtkTexture does not give me any control on how to
> change
> > these parameters.
> >
> > How can i change the these parameters and control the way texture
> > mapping is done. Is there an easy way to do this?
> >
> > Thanks in Advance.
> >
> > Regards
> >
> > Deepak
> >
> >
> > Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
> >
> >
> >
> ------------------------------------------------------------------------
> >
> >
> >
> ------------------------------------------------------------------------
> >
> > _______________________________________________
> > This is the private VTK discussion list.
> > Please keep messages on-topic. Check the FAQ at:
> http://www.vtk.org/Wiki/VTK_FAQ
> > Follow this link to subscribe/unsubscribe:
> > http://www.vtk.org/mailman/listinfo/vtkusers
>
>
> Yahoo! Photos – Showcase holiday pictures in hardcover
> Photo Books
> .
> You design it and we’ll bind it!




Yahoo! Photos
Got holiday prints? See all the ways to get quality prints in your hands ASAP.
_______________________________________________
This is the private VTK discussion list.
Please keep messages on-topic. Check the FAQ at: http://www.vtk.org/Wiki/VTK_FAQ
Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Texture Mapping Problem....Please Help !!!!!

cdeepakroy
In reply to this post by cdeepakroy

Hello again Marc,
 
Regarding visualizing the model in wireframe.
 
I dont understand your suggestion.
 
If there is a closed surface ( or even a concave or convex open surface ) you would always find polygons with normals opposite to each other.
 
For example:
 
two opposite faces of a cube.
 
I dont know what kind of surfaces you were talking about. Could u please explain further ?
 
If you were talking of adjacent polygons with normals facing in opposite directions,
this is hardly possible in the scan of a human body surface. I also visualized my model in wirefram, i found no polygons adjacent like this. Also the places where the cracks are present do not abide to this property.
 
I have attached an image showing the cracks.
 
Regards,
 
Deepak Roy
 
 
 
 
 
 

Marc Cotran <[hidden email]> wrote:
Deepak Roy wrote:

> Hello Marc,
> Thanks for the reply.
> I started working back on this texture issue now, which set aside due
> to other high priority work.
> But when i visualize these surface models, in third party vrml viewers
> the texture comes out well. Its only in my program that i find these
> pattern of cracks.
> What do you think could be the problem ?


Did you try visualizing in wireframe? Do there seem to be any polygons
with normals facing the wrong way? Could you tell me (in pseudo code)
what vtkObjects you are using in your pipeline? Which version of VTK are
you using and on what platform?

Marc

>
> */Marc Cotran /* wrote:
>
> Hi Deepak,
>
> I had experienced similar results before and concluded that the
> polygon
> normals were the culprit. I would suggest visualizing the polydata
> mesh
> in wireframe to see if some of your polygons are oriented opposite to
> the others. I am not sure this is what you're dealing with, but it
> might
> explain your problem. As for a potential solution... I am at a loss.
>
> Should you figure out the problem, I'd love to know the solution.
>
> HTH,
>
> Marc
>
> Deepak Roy wrote:
> >
> > Hello everyone,
> >
> > I have had a hard time trying to fix this texture display problem.
> >
> > Attached is a part of the texture image i am using for the human
> body.
> > I have removed the face and other parts due to some identity
> revealment
> > problems.
> >
> > But the image gives an idea of the problem i am facing. Look at the
> > image and you will see the cracks on the texture.
> >
> > when i visualize the same model in some other standard graphics
> software
> > like Rapid Forms, the texture shows up with out any cracks.
> >
> > I have tried all the possible options with vtkTexture but still
> i could
> > not fix the problem.
> >
> > /"Can anyone explain this phenomenon ? "/
> >
> > One more point to note, which i also mentioned in my previous
> posting to
> > the mailing list, is that exactly the same pattern of cracks
> appear in
> > every model i load.
> >
> > I suspect, it is got to do with clamping or interpolation.
> >
> > Please help me fix this problem.
> >
> > Thanks in Advance.
> >
> > Regards,
> >
> > Deepak Roy
> >
> >
> >
> >
> > Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
> >
> >
> >
> ------------------------------------------------------------------------
> >
> > Subject:
> > Texture Mapping Problem....Please Help !!!!!
> > From:
> > Deepak Roy
> > Date:
> > Fri, 14 Oct 2005 15:42:33 -0700 (PDT)
> > To:
> > [hidden email]
> >
> > To:
> > [hidden email]
> >
> >
> > Hi,
> >
> > I am trying to displaying a 3D surface of a human body with
> texture, all
> > captured from a 3D scan. I am using vtkTecture to assosciate the
> actor
> > with the texture.
> >
> > The problem is:
> >
> > I see a pattern of cracks on surface when displayed with
> texture. These
> > cracks are not present in the basic geometry of the model as the
> surface
> > when visualised without texture appears fine and smooth. I am
> 100% sure
> > that this is the problem with texture mapping.
> >
> > One more thing that was wierd was that i see more or less the same
> > pattern of tracks on each model i display.
> >
> > Could anyone explain the reason why this is happening?
> >
> > I guess the problem is with the edge clamping used while mapping
> the
> > texture. But vtkTexture does not give me any control on how to
> change
> > these parameters.
> >
> > How can i change the these parameters and control the way texture
> > mapping is done. Is there an easy way to do this?
> >
> > Thanks in Advance.
> >
> > Regards
> >
> > Deepak
> >
> >
> > Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
> >
> >
> >
> ------------------------------------------------------------------------
> >
> >
> >
> ------------------------------------------------------------------------
> >
> > _______________________________________________
> > This is the private VTK discussion list.
> > Please keep messages on-topic. Check the FAQ at:
> http://www.vtk.org/Wiki/VTK_FAQ
> > Follow this link to subscribe/unsubscribe:
> > http://www.vtk.org/mailman/listinfo/vtkusers
>
>
> Yahoo! Photos – Showcase holiday pictures in hardcover
> Photo Books
> .
> You design it and we’ll bind it!




Yahoo! Photos
Ring in the New Year with Photo Calendars. Add photos, events, holidays, whatever.
_______________________________________________
This is the private VTK discussion list.
Please keep messages on-topic. Check the FAQ at: http://www.vtk.org/Wiki/VTK_FAQ
Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtkusers

img.JPG (10K) Download Attachment
Loading...