Quantcast

Supported TBB versions?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Supported TBB versions?

Elvis Stansvik
Hi all,

What TBB versions are supported by 7.1.1? Is the one in Ubuntu 16.05
(2015.09.R2-1) sufficient?

Thanks in advance,
Elvis
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Supported TBB versions?

Sujin Philip
Hi Elvis,

We are only using basic TBB features (parallel_for, atomic and enumerable_thread_specific) so it should work with that version. Please let us know if it doesn't work for you.

Thanks
Sujin


On Mon, Apr 10, 2017 at 8:53 AM, Elvis Stansvik <[hidden email]> wrote:
Hi all,

What TBB versions are supported by 7.1.1? Is the one in Ubuntu 16.05
(2015.09.R2-1) sufficient?

Thanks in advance,
Elvis
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers



_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Supported TBB versions?

Elvis Stansvik
2017-04-10 16:07 GMT+02:00 Sujin Philip <[hidden email]>:
> Hi Elvis,
>
> We are only using basic TBB features (parallel_for, atomic and
> enumerable_thread_specific) so it should work with that version. Please let
> us know if it doesn't work for you.

Alright, thanks for the info. I'll have a go at it.

The reason I asked is that I just found out that my build on Ubuntu
was neither using TBB nor OpenMP, so I think the vtkSMPTools I have
will do everything sequentially, so I wanted to fix that :)

Elvis

>
> Thanks
> Sujin
>
>
> On Mon, Apr 10, 2017 at 8:53 AM, Elvis Stansvik
> <[hidden email]> wrote:
>>
>> Hi all,
>>
>> What TBB versions are supported by 7.1.1? Is the one in Ubuntu 16.05
>> (2015.09.R2-1) sufficient?
>>
>> Thanks in advance,
>> Elvis
>> _______________________________________________
>> Powered by www.kitware.com
>>
>> Visit other Kitware open-source projects at
>> http://www.kitware.com/opensource/opensource.html
>>
>> Search the list archives at: http://markmail.org/search/?q=vtk-developers
>>
>> Follow this link to subscribe/unsubscribe:
>> http://public.kitware.com/mailman/listinfo/vtk-developers
>>
>
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/vtk-developers

Loading...