Using VTK master fails on Ubuntu 18.04 due to missing FindPython3.cmake

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Using VTK master fails on Ubuntu 18.04 due to missing FindPython3.cmake

Elvis Stansvik
Trying to build a project against VTK master on Ubuntu 18.04, I get:

CMake Error at /home/estan/orexplore/VTK-inst/lib/cmake/vtk-8.90/VTK-vtk-module-find-packages.cmake:475
(find_package):
  By not providing "FindPython3.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Python3", but
  CMake did not find one.

  Could not find a package configuration file provided by "Python3"
  (requested version 3.6) with any of the following names:

    Python3Config.cmake
    python3-config.cmake

  Add the installation prefix of "Python3" to CMAKE_PREFIX_PATH or set
  "Python3_DIR" to a directory containing one of the above files.  If
  "Python3" provides a separate development package or SDK, be sure it has
  been installed.
Call Stack (most recent call first):
  /home/estan/orexplore/VTK-inst/lib/cmake/vtk-8.90/vtk-config.cmake:92
(include)
  CMakeLists.txt:5 (find_package)


-- Configuring incomplete, errors occurred!

The new FindPython3.cmake was added in CMake 3.12, but Ubuntu 18.04
has CMake 3.10.2.

I know building VTK itself is possible with CMake 3.8+ (this VTK was
built on the same machine).

Should perhaps the installed VTK-vtk-module-find-packages.cmake be
updated so that it can work with the older Python-finding stuff as
well?

Elvis
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
https://vtk.org/mailman/listinfo/vtk-developers

Reply | Threaded
Open this post in threaded view
|

Re: Using VTK master fails on Ubuntu 18.04 due to missing FindPython3.cmake

Elvis Stansvik
Den sön 13 jan. 2019 kl 11:32 skrev Elvis Stansvik
<[hidden email]>:

>
> Trying to build a project against VTK master on Ubuntu 18.04, I get:
>
> CMake Error at /home/estan/orexplore/VTK-inst/lib/cmake/vtk-8.90/VTK-vtk-module-find-packages.cmake:475
> (find_package):
>   By not providing "FindPython3.cmake" in CMAKE_MODULE_PATH this project has
>   asked CMake to find a package configuration file provided by "Python3", but
>   CMake did not find one.
>
>   Could not find a package configuration file provided by "Python3"
>   (requested version 3.6) with any of the following names:
>
>     Python3Config.cmake
>     python3-config.cmake
>
>   Add the installation prefix of "Python3" to CMAKE_PREFIX_PATH or set
>   "Python3_DIR" to a directory containing one of the above files.  If
>   "Python3" provides a separate development package or SDK, be sure it has
>   been installed.
> Call Stack (most recent call first):
>   /home/estan/orexplore/VTK-inst/lib/cmake/vtk-8.90/vtk-config.cmake:92
> (include)
>   CMakeLists.txt:5 (find_package)
>
>
> -- Configuring incomplete, errors occurred!
>
> The new FindPython3.cmake was added in CMake 3.12, but Ubuntu 18.04
> has CMake 3.10.2.
>
> I know building VTK itself is possible with CMake 3.8+ (this VTK was
> built on the same machine).
>
> Should perhaps the installed VTK-vtk-module-find-packages.cmake be
> updated so that it can work with the older Python-finding stuff as
> well?

Nevermind, I realized it was just a matter of making sure
CMake/patches/3.13/FindPython* is installed, to maintain
compatibility.

Ben: I made an MR for this:
https://gitlab.kitware.com/vtk/vtk/merge_requests/5059

Elvis


>
> Elvis
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=vtk-developers

Follow this link to subscribe/unsubscribe:
https://vtk.org/mailman/listinfo/vtk-developers