vtkOpenGLGPUVolumeRayCastMapper Problem on Ubuntu

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

vtkOpenGLGPUVolumeRayCastMapper Problem on Ubuntu

Dirk Fortmeier
Hi everybody,

I got some weird problem. When I try to use the
vtkOpenGLGPUVolumeRayCastMapper I get the following error:

"vtkOpenGLGPUVolumeRayCastMapper (0x28ab6f0): Rendering failed because
the following OpenGL extensions are required but not supported:  OpenGL
1.3 is required but not supported"

VTK compiles and displaying normal gl stuff works fine.

Any ideas what is wrong or how to fix this?

Hints:
- Ubuntu 11.04 (64bit)
- nvidia-current (nvidia driver version 270.xx) and nvidia-current-dev
are installed
- no mesa stuff installed
- VTK from the git repository
- Nvidia Quadro 4000 Chipset

Cheers,

Dirk

--
Dirk Fortmeier <[hidden email]>, PhD Student

Institute of Medical Informatics
Graduate School for Computing in Medicine and Life Sciences
University of Lübeck

Building 64, 2F, Room 4
Ratzeburger Allee 160
23538 Lübeck
Germany

Tel.:+49 (451) 500-5635
Fax.:+49 (451) 500-5610

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Follow this link to subscribe/unsubscribe:
http://www.vtk.org/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|

Re: vtkOpenGLGPUVolumeRayCastMapper Problem on Ubuntu

jdwieber
That's odd for the chipset you listed.  Are you sure your driver is working properly?  AFAIK that card supports up to OpenGL 4.1.  Does running glewinfo show GL_VERSION_1_3 as OK?

/joseph