vtkTestOpenGLVersion header not installed?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

vtkTestOpenGLVersion header not installed?

Andreas Buykx-2

I would like to use the new delayed loading of OpenGL, but found that even when I build VTK with the VTK_USE_OPENGL_DELAYED_LOAD flag the header is not installed in the include directory even though the vtkTestOpenGLVersion.exe is built, so I have to pull it in from the source tree I suppose. Is this intentional?

 

Also I found that it was already available in the 8.1.1 release, but only for the 8.2 release candidate it has been explicitly mentioned. Is the 8.1.1 version OK to use?

 

Thanks!

Andreas

 

DIANA FEA BV

Software Developers and Analysis Consultants for Civil and Geotechnical Engineering

 

Delftechpark 19a, 2628XJ, Delft, The Netherlands

Tel: +31 88 34262 15 (Direct) │ Tel: +31 88 34262 00 (Switchboard) │ Fax: +31 88 34262 99

http://dianafea.com

 


_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
https://public.kitware.com/mailman/listinfo/vtkusers
Reply | Threaded
Open this post in threaded view
|

Re: vtkTestOpenGLVersion header not installed?

VTK - Users mailing list
Thanks, I've added the header to the list of headers to be installed. I suspect the 8.1.1 version should be fine to use as well. - Ken

On Wed, Dec 12, 2018 at 10:01 AM Andreas Buykx <[hidden email]> wrote:

I would like to use the new delayed loading of OpenGL, but found that even when I build VTK with the VTK_USE_OPENGL_DELAYED_LOAD flag the header is not installed in the include directory even though the vtkTestOpenGLVersion.exe is built, so I have to pull it in from the source tree I suppose. Is this intentional?

 

Also I found that it was already available in the 8.1.1 release, but only for the 8.2 release candidate it has been explicitly mentioned. Is the 8.1.1 version OK to use?

 

Thanks!

Andreas

 

DIANA FEA BV

Software Developers and Analysis Consultants for Civil and Geotechnical Engineering

 

Delftechpark 19a, 2628XJ, Delft, The Netherlands

Tel: +31 88 34262 15 (Direct) │ Tel: +31 88 34262 00 (Switchboard) │ Fax: +31 88 34262 99

http://dianafea.com

 

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
https://public.kitware.com/mailman/listinfo/vtkusers


--
Ken Martin PhD
Distinguished Engineer
Kitware Inc.
101 East Weaver Street
Carrboro, North Carolina
27510 USA

This communication, including all attachments, contains confidential and legally privileged information, and it is intended only for the use of the addressee.  Access to this email by anyone else is unauthorized. If you are not the intended recipient, any disclosure, copying, distribution or any action taken in reliance on it is prohibited and may be unlawful. If you received this communication in error please notify us immediately and destroy the original message.  Thank you.

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ

Search the list archives at: http://markmail.org/search/?q=vtkusers

Follow this link to subscribe/unsubscribe:
https://vtk.org/mailman/listinfo/vtkusers